Velkommen
Brugernavn:

Kodeord:




Husk mig

[ ]
Tæller
Denne side idag
I alt: 0
Unikke: 0

Denne side nogensinde
I alt: 5148
Unikke: 2194

Site ...
I alt: 340521
Unikke: 60102
Vælg sprog


Forums
PCLinuxOS.dk :: Forums :: Tips and Tricks
<< Forrige indlæg | Næste indlæg >>   

Skrive til NTFS

Ophavsmand Indlæg
allanadmin
ons jul 18 2007, 17:52 Vis Udskrift

allanadmin

Oprettet: tor feb 08 2007, 17:58
Indlæg: 1049
Skrive til NTFS

ntfs-3g problem


after clean install and full update, ntfs-3g doesn`t works...here is my fstab

/dev/hda6 / ext3 defaults 1 1
/dev/hda1 /mnt/win_c ntfs-3g defaults,user,exec,noauto,locale=bg_BG.UTF-8 0 0
/dev/hda5 /mnt/win_d ntfs-3g defaults,user,exec,noauto,locale=bg_BG.UTF-8 0 0
...

i used ntfs-config, it have to be ok, but partitions are even not mounted, and give errors after clicking them

and here is the message after trial to mount them

downgraded ntfs-config to available in the repo 0.5.5 version, then uncheck "enable support", apply, and then check "enable support..", apply again, and voala: it works

Den kan lade sig gøre men det er lidt farligt
Tag backup
Forsætter :

Let me correct your info a little.
In System-Configuration- Hardware open NTFS Configuration Tool (root password is wanted)- in the new small window enable ntfs write support for the type of ntfs device which you want (internal, external or both) and press OK.
Nothing more is wanted, selected types of ntfs device are ready for permanent writting now (it means even after system rebooting because fstab file has been changed).
It is quite unavailing to open KDisk Free after last operation. Only you will see your ntfs partitions are already mounted.
If you want to return your system to default settings (ntfs devices for read only) simply uncheck support for writing in NTFS Configuration Tool. Again it is permanent operation (fstb file is re-writed back).

**********

However, I can still not mount the ntfs drive as a non-root user. I still receive permission errors. ntfs-config causes my fstab entry to read:
/dev/hdb2 /mnt/win_m ntfs-3g defaults,users,exec,noauto,locale=en_US.UTF-8 0 0

If I modify it to read

/dev/hdb2 /mnt/win_m ntfs-3g defaults,locale=en_US.UTF-8 0 0

the inode errors are corrected and all I receive is a simple "permission denied" error

I can even try to add "user=501" to the fstab entry and I still have "permission denied" errors.

Any idea how to get this to work as a user and not as root?

Svar :

OK, following a hint from another forum, I got this one fixed. It required two changes, both of which I hope the devs will correct in the repositories.

1) install the FUSE-dkms kernel driver from the repositories. It would appear that until the kernel version in stable is upgraded, this driver is required

2) set the ntfs-3g binary to SUID as root

With these two changes, I can now mount and unmount my NTFS partitions as a local user.

Tilbage til toppen

Bestyrer: allanadmin

Gå til:     Tilbage til toppen

Powered by e107 Forum System
Chatboks
allanadmin
04 dec : 13:51
Så kom December nummeret af vores blad

allanadmin
04 aug : 21:45
Nyt Magesin

allanadmin
31 dec : 11:40
Godt Nytår og Glædelig Jul herfra

allanadmin
03 dec : 13:41
Og Glædelig Jul Herinde

allanadmin
03 dec : 13:41
Nyt blad for December måned