Velkommen
Brugernavn:

Kodeord:




Husk mig

[ ]
Tæller
Denne side idag
I alt: 0
Unikke: 0

Denne side nogensinde
I alt: 5148
Unikke: 2194

Site ...
I alt: 340499
Unikke: 60101
Vælg sprog


Forums
PCLinuxOS.dk :: Forums :: Tips and Tricks
<< Forrige indlæg | Næste indlæg >>   

Gør icon større

Ophavsmand Indlæg
allanadmin
tir sep 11 2007, 20:54 Vis Udskrift

allanadmin

Oprettet: tor feb 08 2007, 17:58
Indlæg: 1049
ALWAYS ALWAYS ALWAYS - Make a backup of your xorg.conf file prior to any editing. This will insure no matter what you mess up you'll have a good chance on getting back to the gui. My method is to copy xorg.conf as xorg.orig1 in the same directory (/etc/X11 in PCLinuxOS). Then you need only log in as root and enter:
Code:

cd /etc/X11
mv xorg.conf xorg.bad1
cp xorg.orig1 xorg.conf

And try again. The commands above will also leave the "bad" config file available for review to see what you did wrong. As you make progressive edits on a new install, use .orig2 and .bad2 and so on until you're satisified with the final copy. You can then remove all the backups and bads if you want, however keeping a backup of the last xorg.conf.

LCD monitors look much better with sharp fonts and proper dpi settings.
Here's how to set your xorg KDE install to 100 dpi (or whatever dpi you prefer).
First of all let me state that I have most of my experience with nvidia cards. I think this particular topic is universal but if you have a different experience or tips to add by all means, post them here. Let's build a great "how to."

I am assuming that you've got your monitor and video card set at their best.

To determine what dpi you are at, in a console type:

xdpyinfo |grep resolution

Of course, you would have to have the xdpyinfo tool installed but I think it default installs with pclos.
In my initial install I got this result;

resolution: 83x86 dots per inch

Unfortunately, this dpi is not anything like any of the fonts available. The default KDE fonts are 75x75, windows fonts are 96x96, and the high resolution KDE fonts are 100x100. The fix is pretty easy.

To get to 100x100 dpi fonts:

As root; edit the monitor section of /etc/X11/xorg.conf to include these lines;

Option "UseEDIDDpi" "false" <-----turns off automatic dpi detection
Option "Dpi" "100x100" <---or whatever size you want

With synaptic, search and install all the 100 dpi fonts. While you're at it, install the liberation fonts package - they are made to be clear on LCD's

As root; edit /etc/X11/fs/config:

Look for: "default-resolutions = 75,75,100,100"
Edit it to read: "default-resolutions = 100,100,75,75"
You can amend the remarks too if you're anal like me... Cheesy

Then under "catalogue = ..." rearrange the order so the 100dpi fonts are listed first, like this:

From this:
catalogue = /usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/misc:unscaled,

To this:
catalogue = /usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/misc:unscaled,

The 'Section "Files"' in your /etc/X11/xorg.conf should look something like
Section "Files"
# font server independent of the X server to render fonts.
FontPath "unix/:-1"
# minimal fonts to allow X to run without xfs
FontPath "/usr/share/fonts/100dpi:unscaled" <----make sure 100dpi fonts are listed ahead of all the others
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/misc:unscaled"

At this point you need to restart X for these changes to take effect.

That's it! You may want to go into mozilla firefox or seamonkey and reset your font sizes larger. Also open KMENU>SYSTEM>CONFIGURATION>KDE>APPEARANCE...>FONTS and set the fonts to your liking and enable (or disable if you prefer) anti-aliasing.

I'd like to hear some feedback on this how-to...
Tilbage til toppen

Bestyrer: allanadmin

Gå til:     Tilbage til toppen

Powered by e107 Forum System
Chatboks
allanadmin
04 dec : 13:51
Så kom December nummeret af vores blad

allanadmin
04 aug : 21:45
Nyt Magesin

allanadmin
31 dec : 11:40
Godt Nytår og Glædelig Jul herfra

allanadmin
03 dec : 13:41
Og Glædelig Jul Herinde

allanadmin
03 dec : 13:41
Nyt blad for December måned