Velkommen
Brugernavn:

Kodeord:




Husk mig

[ ]
Tæller
Denne side idag
I alt: 1
Unikke: 1

Denne side nogensinde
I alt: 4927
Unikke: 2055

Site ...
I alt: 288892
Unikke: 49959
Vælg sprog


Forums
PCLinuxOS.dk :: Forums :: Hardware
<< Forrige indlæg | Næste indlæg >>   

DELL Latitude med to skærme

Ophavsmand Indlæg
slamidtfyn
tor apr 10 2008, 15:33 Vis Udskrift
Registeret medlem #79
Oprettet: tor feb 14 2008, 23:29
Indlæg: 9
Hejsa Linux'er

Er der nogen der har erfaring med at få en laptop til at virke med en extern monitor, dvs så der er billede på både laptoppen og den extra skærm. (som 2 separate monitorer og ikke bare det samme billede på begge 2)

Jeg sidder med en DELL Latitude D640 og en DELL 1704FP, men ligeså snart jeg logger ind på Gnome desktoppen slukker skærmen på den bærbare og så har jeg kun billede på den externe skærm. (Ved boot er samme billede på begge skærme)

UPDATE:
Jeg har prøvet følgende konfiguration uden held:

# File generated by XFdrake (rev 57713)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # font server independent of the X server to render fonts.
    FontPath "unix/:-1"
    
    # minimal fonts to allow X to run without xfs
    FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Extensions"
    Option "Composite"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri" # direct rendering
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "dk"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
    Identifier "SynapticsMouse1"
    Driver "synaptics"
    Option "SHMConfig" "on"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Dell"
    ModelName "Dell 1024x768 Laptop Display Panel"
    HorizSync 31.5-48.5
    VertRefresh 59.0-75.0
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Monitor"
    Identifier "monitor2"
    VendorName "Dell"
    ModelName "Dell 1704FPV (Analog)"
    HorizSync 30.0-81.0
    VertRefresh 56.0-76.0
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName ""
    BoardName "ATI Radeon 9250 and earlier"
    Driver "ati"
    Option "DPMS"
    Option "AccelMethod" "EXA"
    Option "XaaNoOffscreenPixmaps" "1"
    Option "BIOSHotkeys"
    Screen 0
EndSection

Section "Device"
    Identifier "device2"
    VendorName ""
    BoardName "ATI Radeon 9250 and earlier"
    Driver "ati"
    Option "DPMS"
    Option "XaaNoOffscreenPixmaps" "1"
    Option "AccelMethod" "EXA"
    Option "BIOSHotkeys"
    Screen 1
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection


Section "Screen"
    Identifier "screen2"
    Device "device2"
    Monitor "monitor2"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen      0 "Screen1" 0 0
    Screen      1 "Screen2" RightOf "Screen1"

    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "SynapticsMouse1" "AlwaysCore"
    
EndSection


[ Redigeret tor apr 10 2008, 16:15 ]
Tilbage til toppen
allanadmin
fre apr 11 2008, 11:31

allanadmin

Oprettet: tor feb 08 2007, 17:58
Indlæg: 1030
Nej jeg har ingen erfaring med det. Jeg syntes det lyder ret "normalt" at når den ene er tændt slukker den anden.
Kræver det ikke et grafikkort der kan have 2 skærme ? kan det være noget oppe i BOIS ? altså en maskin opsætning mere end en Software opsætning ?
Tilbage til toppen
allanadmin
fre apr 11 2008, 11:38

allanadmin

Oprettet: tor feb 08 2007, 17:58
Indlæg: 1030
http://www.pclinuxos.com/index.php?option=com_smf&Itemid=58&topic=41588.0
Tilbage til toppen
allanadmin
fre apr 11 2008, 11:40

allanadmin

Oprettet: tor feb 08 2007, 17:58
Indlæg: 1030
I have the same problem as mentioned above but, I after I two tries I get to a black screen with "ati (my driver version)etc.etc. is already installed on this kernel" and "ndiswrapper (my driver version number) etc.etc. is already installed on this kernel". It only happens when
I have Compiz-Fusion enabled,
otherwise I can login just fine. I tried the fix mentioned above but to no avail. I am running a Gateway Laptop with an ATI Mobility Radeon X600, and a Broadcom 43xx wireless card. Any ideas?
Tilbage til toppen

Bestyrer: allanadmin

Gå til:     Tilbage til toppen

Powered by e107 Forum System
Chatboks
allanadmin
03 dec : 13:41
Og Glædelig Jul Herinde

allanadmin
03 dec : 13:41
Nyt blad for December måned

allanadmin
03 aug : 11:51
Bladet for August er kommet

allanadmin
05 jul : 09:59
Nyt Blad

allanadmin
13 jun : 12:13
Velkommen til Torkel Sprove